diff src/configure.ac @ 26177:13e09dc59f0f v8.2.3620

patch 8.2.3620: memory leak reported in libtlib Commit: https://github.com/vim/vim/commit/b3a29558eedac9979f5276ae914934b7b7cbe06b Author: Bram Moolenaar <Bram@vim.org> Date: Fri Nov 19 11:28:04 2021 +0000 patch 8.2.3620: memory leak reported in libtlib Problem: Memory leak reported in libtlib. Solution: Call del_curterm() when cleaning up memory. Rename term.h to termdefs.h to avoid a name clash.
author Bram Moolenaar <Bram@vim.org>
date Fri, 19 Nov 2021 12:30:05 +0100
parents d7e1cf30728c
children b74e4c3618f8
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -3591,6 +3591,16 @@ AC_TRY_COMPILE([
 	AC_MSG_RESULT(yes); AC_DEFINE(HAVE_OUTFUNTYPE),
 	AC_MSG_RESULT(no))
 
+AC_MSG_CHECKING([whether del_curterm() can be used])
+AC_TRY_LINK([
+#ifdef HAVE_TERMCAP_H
+# include <termcap.h>
+#endif
+#include <term.h>
+			], [if (cur_term) del_curterm(cur_term);],
+	AC_MSG_RESULT(yes); AC_DEFINE(HAVE_DEL_CURTERM),
+	AC_MSG_RESULT(no))
+
 dnl On some SCO machines sys/select redefines struct timeval
 AC_MSG_CHECKING([whether sys/select.h and sys/time.h may both be included])
 AC_TRY_COMPILE([