diff src/configure.ac @ 20077:128963cd954f v8.2.0594

patch 8.2.0594: MS-Windows: cannot build with WINVER set to 0x0501 Commit: https://github.com/vim/vim/commit/b6fb0516ec862a18fdffe06c9400d507a7193835 Author: Bram Moolenaar <Bram@vim.org> Date: Sat Apr 18 18:24:18 2020 +0200 patch 8.2.0594: MS-Windows: cannot build with WINVER set to 0x0501 Problem: MS-Windows: cannot build with WINVER set to 0x0501. Solution: Only use inet_ntop() when available. (Ozaki Kiichi, closes https://github.com/vim/vim/issues/5946)
author Bram Moolenaar <Bram@vim.org>
date Sat, 18 Apr 2020 18:30:03 +0200
parents e373843e2980
children 06cc64c7b0cb
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -2077,6 +2077,7 @@ if test "$enable_channel" = "yes"; then
 
   if test "x$vim_cv_ipv6_networking" = "xyes"; then
     AC_DEFINE(FEAT_IPV6)
+    AC_CHECK_FUNCS(inet_ntop)
   else
     dnl On Solaris we need the nsl library.
     AC_CHECK_LIB(nsl, gethostbyname)