diff src/configure.ac @ 20095:06cc64c7b0cb v8.2.0603

patch 8.2.0603: configure does not detect moonjit Commit: https://github.com/vim/vim/commit/f49e5640821d8ef752fb50d99edcf40bb62a4d4d Author: Bram Moolenaar <Bram@vim.org> Date: Sun Apr 19 17:46:53 2020 +0200 patch 8.2.0603: configure does not detect moonjit Problem: Configure does not detect moonjit. Solution: Add check for moonjit. (Shlomi Fish, closes https://github.com/vim/vim/issues/5947)
author Bram Moolenaar <Bram@vim.org>
date Sun, 19 Apr 2020 18:00:03 +0200
parents 128963cd954f
children 78f018fef092
line wrap: on
line diff
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -625,7 +625,26 @@ if test "$enable_luainterp" = "yes" -o "
 	  LUA_INC=/lua$vi_cv_version_lua
 	else
 	  AC_MSG_RESULT(no)
-	  vi_cv_path_lua_pfx=
+
+	  # Detect moonjit:
+	  # https://groups.google.com/forum/#!topic/vim_use/O0vek60WuTk
+	  lua_suf=/moonjit-2.3
+	  inc_path="$vi_cv_path_lua_pfx/include"
+	  for dir in "$inc_path"/moonjit-[0-9]* ; do
+	    if test -d "$dir" ; then
+	      lua_suf=`basename '$dir'`
+	      lua_suf="/$lua_suf"
+	      break
+	    fi
+	  done
+	  AC_MSG_CHECKING(if lua.h can be found in $inc_path$lua_suf)
+	  if test -f "$inc_path$lua_suf/lua.h"; then
+	    AC_MSG_RESULT(yes)
+	    LUA_INC=$lua_suf
+	  else
+	    AC_MSG_RESULT(no)
+	    vi_cv_path_lua_pfx=
+	  fi
 	fi
       fi
     fi